Chrome console errors generated when browsing

Description

We produced an error in our Chrome console log while doing some testing for this user reported issue - https://tidepoolsupport.zendesk.com/agent/tickets/14699

We suspect there may be an issue with the user's account and or data contributing to the problems they reported so we would like to investigate these console logs to know if they are related or could also indicate any issues with the account or data.

Error:
d3 error Error: <path> attribute d: Expected number, "…6.25 H-5166.92 MNaN,6.25 HNaN MN…

Steps to reproduce:

  • access affected account via support@tidepool.org , you will be directed to the basics view

  • click on trends view

  • with the 2 week filter on, click the back arrow twice, resulting in the dates sept 28th - 0ct 1st

  • Click on daily view, you should now be on Oct 1st 2020

  • in the console log there should be a d3 error Error: <path> attribute d: Expected number, "…6.25 H-5166.92 MNaN,6.25 HNaN MN…

Done Criteria

User is able to browse the Tidepool web views for their account without generating errors.

Also determine if the cause for this could be contributing to or confirming the findings in: https://tidepool.atlassian.net/browse/WEB-1099

Design Specifications:

None

Accessibility Specifications

None

Test Strategy

None

Environment

None

Priority

None

Assignee

Unassigned

QA Assignee

None

Reporter

Dave Cintron

Requested By (External)

None

Fix versions

None

T-Shirt Size

None

Risk Level

None

User Experience Assessment Level

3

UEA: Issue Volume

7P + 3A + (1) + (2) + D = 3

UEA: Category

Users Confused

Components

None

Design Review Required?

None

Design Approved By:

None

QA done during validation of another ticket?

None

Accessibility Review Required?

None

Accessibility Review Approved By

None

Approved for Production By:

None

Marketing Comms

None

Support Follow Up

Yes

KB Update

None

Pull Request Needed

None

Resolved Build #

None

Reason for Deferral

None
Configure